Exchange 2010 SP1 Rollup 3 not installing

Recent customer onsite job I had to setup Exchange rollup 3 for the Exchange servers with fingers cross to fix some of the existing issues. Environment consists of 2 HUB/CAS in NLB mode and 2 MBX servers in DAG.

Previously I’ve already applied rollup 2 for all servers. During the rollup 3 setup to one of the HUB/CAS servers I’ve been thrown with an error of “The user who’s currently logged on doesn’t have sufficient permissions to install this package. You need at least Exchange Server Administrator permissions on the current computer to complete the task.”

Since I’ve used the same user account for the pervious machine rollup 3 update I know there is no permission issues for the account. To isolate the issue I tried running the update with logging enable by using the following command,

Exchange2010-KB2529939-v3-x64-en.msp /lxv* c:\Rollupdat3.log

Error log didn’t help much with the given details apart from pointing out ,” Exchange ADAccess service not being able to access AD” This can be easily fix by restarting the “Microsoft Exchange Active Directory Topology” service. No luck when ran the rollup.

Did some research on the net to see if I’m the only guy with this pain J According to the internet search I did, one of the fix that did work for me is,

1. Stop the Exchange services, IIS Admin, WWW, Windows Search (Exchange) and WMI service.

2. Restart the server and trying the setup again.

Exchange 2010 SP1 Rollup 3 update can be obtained from here.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s